易语言mysql数据库相关操作

浏览 13 次     时间 2021-08-26 21:57:34     作者 有勇气的牛排    标签 易语言

1 数据库表

在这里插入图片描述

2 连接数据库

失败返回 0

数据库句柄 = 连接MySql (“127.0.0.1”, “用户名”, “密码”, “数据库名”, 3306)
调试输出 (数据库句柄)

3 增加数据

SQL = 取文本 (“insert into Euser values ('%s','%s');”, “1666”, “2666”)
.版本 2
.支持库 mysql
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 SQL, 文本型
.局部变量 记录集句柄, 整数型
.局部变量 数据内容, 文本型, , "2"

数据库句柄 = 连接MySql (“127.0.0.1”, “root”, “root”, “students”, 3306)
调试输出 (数据库句柄)
.如果真 (数据库句柄 = 0)
    信息框 (“请检查您的mysql数据库是否安装正常”, 0, , )
    结束 ()
.如果真结束

SQL = 取文本 (“insert into Euser values ('%s','%s');”, “1666”, “2666”)
执行SQL语句 (数据库句柄, SQL)
断开MySql (数据库句柄)

4 查询

4.1 精确查询

SQL = 取文本 (“select * from Euser where Name = '666'”, )

4.2 模糊查询(只知道前半段)

SQL = 取文本 (“select * from Euser where Name like '1%'”, )

4.3 模糊查询(只知道中间)

SQL = 取文本 (“select * from Euser where Name like '%6%'”, )

4.4 模糊查询(只知道后半段)

SQL = 取文本 (“select * from Euser where Name like '%7'”, )

4.5 查询并输出所有符合条件的内容 案例

.版本 2
.支持库 mysql
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 SQL, 文本型
.局部变量 记录集句柄, 整数型
.局部变量 数据内容, 文本型, , "2"

数据库句柄 = 连接MySql (“127.0.0.1”, “root”, “root”, “students”, 3306)
调试输出 (数据库句柄)

.如果真 (数据库句柄 = 0)
    信息框 (“请检查您的mysql数据库是否安装正常”, 0, , )
    结束 ()
.如果真结束

连接MySql (, , , , )
SQL = 取文本 (“select * from Euser where Name = '666'”, )
调试输出 (SQL)

调试输出 (执行SQL语句 (数据库句柄, SQL))

记录集句柄 = 取记录集 (数据库句柄)

.计次循环首 (取记录集行数 (记录集句柄), )
    清除数组 (数据内容)
    加入成员 (数据内容, “”)
    加入成员 (数据内容, “”)
    读字段值 (记录集句柄, “Name”, 数据内容 [1])
    读字段值 (记录集句柄, “psd”, 数据内容 [2])
    调试输出 (数据内容)
    到下一行 (记录集句柄)
.计次循环尾 ()

' 断开数据库
断开MySql (数据库句柄)

5 删除数据

SQL = “delete from Euser where Name = '666'”
.版本 2
.支持库 mysql
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 SQL, 文本型
.局部变量 记录集句柄, 整数型
.局部变量 数据内容, 文本型, , "2"

数据库句柄 = 连接MySql (“127.0.0.1”, “root”, “root”, “students”, 3306)
调试输出 (数据库句柄)

.如果真 (数据库句柄 = 0)
    信息框 (“请检查您的mysql数据库是否安装正常”, 0, , )
    结束 ()
.如果真结束

连接MySql (, , , , )
SQL = “delete from Euser where Name = '666'”
执行SQL语句 (数据库句柄, SQL)

' 断开数据库
断开MySql (数据库句柄)

6 更新

SQL = 取文本 (“update 表名 set Name = '%s' where Name = '%s'”, “666”, “180”)
.版本 2
.支持库 mysql
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 SQL, 文本型
.局部变量 记录集句柄, 整数型
.局部变量 数据内容, 文本型, , "2"

数据库句柄 = 连接MySql (“127.0.0.1”, “root”, “root”, “students”, 3306)
调试输出 (数据库句柄)

SQL = 取文本 (“update Euser set Name = '%s' where Name = '%s'”, “666”, “180”)
调试输出 (SQL)
执行SQL语句 (数据库句柄, SQL)

调试输出 (执行SQL语句 (数据库句柄, SQL))

' 断开数据库
断开MySql (数据库句柄)
版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。